1

Topic: Tinymce not working with Internet Explorer 9.0

How can we fix this bug?

2

Re: Tinymce not working with Internet Explorer 9.0

What bug?

Greetings from Germany,

Felix Riesterer.
(-> about me and this forum <-)

3

Re: Tinymce not working with Internet Explorer 9.0

I can't see the textarea's inside. I can't write anything.

4

Re: Tinymce not working with Internet Explorer 9.0

We reported a bunch of bugs the day after release. It's things Microsoft needs to fix since they are clear regressions. Don't use that beta unless for testing.

Best regards,
Spocke - Main developer of TinyMCE

5

Re: Tinymce not working with Internet Explorer 9.0

What's quite bad is that big websites like dailymotion have nag screen with messages like : "Update to Internet Explorer 9 to try our HTML5 Player
A new version of Internet Explorer is available, and it's compatible with our HTML5 Player Beta".

While browsing the internet, I visited 3 or 4 others websites telling users to update to IE9 because it's so much better... That's just stupid to tell users to update to a beta version of a browser... Actually, it should only be used by developers and people who don't care or who want to try stuff even if things are broken.

PC Tuning - Radio dance, Let's Go Zik
O2 Graphics, web agency in Saint-Etienne, France

6

Re: Tinymce not working with Internet Explorer 9.0

Yes, that is quite stupid. Not much we can do about it though since basic things like caching doesn't work correctly on IE 9. So it's basically useless in it's current state. We might release a patched version if Microsoft doesn't resolve some of the bugs but some of them must be fixed by them and our hands are tied.

Best regards,
Spocke - Main developer of TinyMCE

7

Re: Tinymce not working with Internet Explorer 9.0

Are you sure?
See: http://blog.switchsystems.co.uk/2010/09 … weve-done/

8

Re: Tinymce not working with Internet Explorer 9.0

Yes, there are a lot more issues. I started working on some of them yesterday things like onload doesn't fire correctly, CSS clip attribute isn't working, the browser crashes when it executes the unit tests other unit tests fails since it returns the wrong output, missing range methods that are available in other browsers. So I guess it will be a lot more issues if we ever get it working on the beta. But before I manage to fix all those issues M$ might have releases their beta 2 and resolved many of the issues so then it would just have been a waste of time.

But we might release a minor bug fix release if we manage to work around the most serious issues.

Best regards,
Spocke - Main developer of TinyMCE

9

Re: Tinymce not working with Internet Explorer 9.0

Hi spocke, yes I would release a ...1 with just those fixes. They unlock a quite good chunk of functionality.

10

Re: Tinymce not working with Internet Explorer 9.0

Hey Spocke. Yah, a few strange issues with TinyMCE in IE9. I'm sure you are aware, but thought I'd throw my finds into the mix.

First off, all CSS loads as it should.  All font and style formatting functions seem to work as expected. I can type in the editor and move existing images around as I always have.  So, not a whole lot of issues from what I can see.

However, I did find a couple of biggies (note that I have not made a single alteration to your tiny_mce.js file and it is the most current version)...

********************************************************************************************************************************
********************************************************************************************************************************
Issue #1

--- Advanced Mode and Simple Mode Issue ---

When TinyMCE first tries to load in IE9, it visually loads all the icons and renders my CSS, but then throws up the follow error (5 times in a row) that says (in Microsoft's typical cryptic error format)

Object doesn't support this property or method
tiny_mce.js
Line: 1
Char: 20815
********************************************************************************************************************************
********************************************************************************************************************************
Issue #2

--- Advanced Mode ONLY Issue ---

If an icon I click on in the tool bar of the TinyMCE editor requires a popup it won't launch and references the same Char: 20815 error, but only once.  The outline of the popup is there along with the close button, but the contents of the popup don't load.

********************************************************************************************************************************
********************************************************************************************************************************
Issue #3

--- Simple Mode ONLY Issue ---

When I first try to type in the TinyMCE editor textarea the cursor won't appear unless I click on the first line of the editor window.  If I click below where the cursor should start blinking the upper left-hand corner, nothing happens. But if I click to the right of it, then it works and I can start typing.  And then if you click below where it's blinking the cursor disappears again.

********************************************************************************************************************************
********************************************************************************************************************************
Issue #4

--- Simple Mode ONLY Issue ---

When I get passed Issue #3 and start to type a character, an error popup appears referencing tiny_mce.js again, but this type Char: 151153. I close the error window and type another character and it pops up again.  The same error reference also appears if I try to highlight anything and if I click on any of the lower icons.

********************************************************************************************************************************
********************************************************************************************************************************

Alright. That's all I could find for now.  Hope this is helpful.

11

Re: Tinymce not working with Internet Explorer 9.0

I have some problems with IE9beta, and I upgrade to tinyMCE 3.3.9.1 today.
Most of my problems are now fixed.

One is still problematic: the same  as Sethplate. With, IE9, it is impossible to put cursor in the textarea.

It's working:
* IE9beta with compatibility mode
* Directly with tinymce example (http://tinymce.moxiecode.com/examples/full.php )

I think the different configurations explain this problem: I'm still looking what is the option to change


Fabrice.

Last edited by fabriceOb (2010-09-23 17:27:11)

12

Re: Tinymce not working with Internet Explorer 9.0

@CF_freak: Please re-test using the latest version.
@fabriceOb: If you manage to pinpoint the issue let me know. Might need to report it to M$.

Best regards,
Spocke - Main developer of TinyMCE

13

Re: Tinymce not working with Internet Explorer 9.0

I've got som "new" elements. Sorry for the delay sometimes, I forget the basics.

In fact, it is possible to put cursor in the textarea, but some conditions have to be respect. You cannot put cursor after the last line. It's not clear ? Some exemples. The I is the place where I try to clic.

Empty content working :

<p>I</p>

Empty content not working :

<p></p>
I
I<p></p>

=> it is not possible to place the cursor, except in an existing content. Difficult to target when the block p is invisible

Clicking at the bottom of the full example, the problem is visible.

Fabrice.

Last edited by fabriceOb (2010-09-27 11:51:23)

14

Re: Tinymce not working with Internet Explorer 9.0

TinyMCE has never had any support for putting the caret at a position that doesn't exist. However IE9 have an issue where it's possible to select the HTML element. So I just added a fix for that to the GitHub version.

Best regards,
Spocke - Main developer of TinyMCE

15

Re: Tinymce not working with Internet Explorer 9.0

3.3.9.2 plz? smile
I am using the jQuery compressed version wink

16

Re: Tinymce not working with Internet Explorer 9.0

spocke wrote:

@CF_freak: Please re-test using the latest version.
@fabriceOb: If you manage to pinpoint the issue let me know. Might need to report it to M$.

Hey Spocke, any chance I might find a list of what files were changed. I've made a few modifications to some of the source throughout the previous version and if it's just the tiny_mce.js that was updated, that would be great to know.

Thanks.

17

Re: Tinymce not working with Internet Explorer 9.0

tiny_mce.js is always updated since it's built from the files in the classes directory. You can use GitHub to see modified files between two versions.

Best regards,
Spocke - Main developer of TinyMCE

18

Re: Tinymce not working with Internet Explorer 9.0

I just tried 3.3.9.2 and I'm still having some problems with IE9 beta (in IE9 browser more and standards document mode).  I'm using the bbcode example from http://tinymce.moxiecode.com/examples/example_09.php, only I'm using the jquery TinyMCE version.  The editor renders fine, but there's no carat.  I can only get the carat after I click one of the formatting buttons, like the bold button.

19

Re: Tinymce not working with Internet Explorer 9.0

One more IE 9, this one is weird (version 3.3.9.2): click on bold, type some text, hit enter. The caret will jump back to the previous line.

20

Re: Tinymce not working with Internet Explorer 9.0

Won't be fixing this one since it's a regression in behavior on IE 9 and it has been reported. It's now producing DIV as it's default block type instead of P. And that seems to make the caret stick to that line some how.

Best regards,
Spocke - Main developer of TinyMCE

21

Re: Tinymce not working with Internet Explorer 9.0

I have the same issues with TinyMCE in IE9, can't type anything. Any ideas?

22

Re: Tinymce not working with Internet Explorer 9.0

Upgrade the latest 3.4 or 3.3 versions both work perfectly fine with IE 9.

Best regards,
Spocke - Main developer of TinyMCE

23

Re: Tinymce not working with Internet Explorer 9.0

I am running tinymce MajorBuild 3 Minor 3.9.3
IE 9 (as of Fridays Build)
In IE9 Compatiblity Mode , IE9 Document Mode- Nothing works in TinyMCE. No Bold, No Italic,No Href etc..
If I set the "Document Mode" to IE8 it works. It also effects MooTOOLS pre 2.3

This is definatly an IE BUG. However if you guys can find a way to make it work without me getting a call from all of our users, i would love it, if not, my life is going to need lots of BEER!

Last edited by roblem (2011-03-21 20:14:54)

24

Re: Tinymce not working with Internet Explorer 9.0

Upgrade and it will work. We have no issues with IE9 3.3.9.3 and 3.4 both work fine on IE 9 and all unit tests are passing.

Best regards,
Spocke - Main developer of TinyMCE

25

Re: Tinymce not working with Internet Explorer 9.0

I have the same problem as above, none of the icons do anything when using IE9. Bold, Italic, etc.. none of them do anything when you click on them.

I have upgraded to 3.4.2 which was released on 2011-04-07 and still nothing works. I also cleared the browser cache and rebooted just to make sure the old file wasn't hanging around.

I am at a loss for what to do now. Any suggestions?

Thank you.