This plugin contains a few compatibility files for the old 3.x branch. This enables you to run most old 3.x plugins with out any modifications. You need to take a few steps to enable this plugin:

Installation

  1. Download the tinymce development package.
  2. Copy the compat3x plugin to your site.
  3. Copy utils and tiny_mce_popup.js to the root directory if tinymce where the tinymce.min.js file is located.
  4. Add the compat3x plugin as your first plugin in the plugins init option or load it after the TinyMCE core.
  5. (Optional) rename the old plugins editor_plugin.js file to plugin.min.js then you can load it as a normal plugin.

Example of usage in tinymce.init

tinymce.init({
plugins: "compat3x",
external_plugins: {
"myoldplugin": "/tinymce/plugins/myoldplugin/editor_plugin.js"
}
});

Example of loading the compat3x before tinymce.init

<script src="/tinymce/tinymce.min.js"></script>
<script src="/tinymce/plugins/compat3x/plugin.min.js"></script>
<script>
tinymce.init({
external_plugins: {
"myoldplugin": "/tinymce/plugins/myoldplugin/editor_plugin.js"
}
});
</script>