0 results found

3.x Compatibility Plugin

Run old plugins on version 4.

Contribute to this page

This plugin contains a few compatibility files for the old 3.x branch. This enables you to run most old 3.x plugins without any modifications. You need to take a few steps to enable this plugin:

Installation Instructions

  1. Download the TinyMCE development package.
  2. Copy the compat3x plugin to your site.
  3. Copy utils and tiny_mce_popup.js to the root directory, if tinymce where the tinymce.min.js file is located.
  4. Add the compat3x plugin as your first plugin in the plugins init option or load it after the TinyMCE core.
  5. (Optional) Rename the old plugins editor_plugin.js file to plugin.min.js then you can load it as a normal plugin.

Type: String

Example

Example of usage in tinymce.init:

tinymce.init({
  selector: "textarea",  // change this value according to your HTML
  plugins: "compat3x",
  external_plugins: {
    "myoldplugin": "/tinymce/plugins/myoldplugin/editor_plugin.js"
  }
});

Example of loading the compat3x before tinymce.init:

<script src="/tinymce/tinymce.min.js"></script>
<script src="/tinymce/plugins/compat3x/plugin.min.js"></script>
<script type="text/javascript">
tinymce.init({
  selector: "textarea",  // change this value according to your HTML
  external_plugins: {
    "myoldplugin": "/tinymce/plugins/myoldplugin/editor_plugin.js"
  }
});
</script>

Except as otherwise noted, the content of this page is licensed under the Creative Commons BY-NC-SA 3.0 License, and code samples are licensed under the Apache 2.0 License.